Tasks using code execution or file generation failed
Resolved
Sep 3, 2026 at 5:39am UTC
Resolved. Our infrastructure provider has closed their incident and all regions are reported fully operational.
Summary: tasks that run code, generate files, or execute shell commands failed to start between 01:44 and 02:01 UTC (approximately 17 minutes), with reduced reliability and slower start times continuing until 02:16 UTC. Since then we have recorded no failed sandbox provisioning attempts and no elevated latency across several hours of normal traffic.
Everything is working normally. If a task of yours failed during the window above, simply run it again. Thank you for your patience.
Affected services
Updated
Sep 3, 2026 at 2:49am UTC
Our error rates are back to baseline. No task has failed to start since 02:01 UTC, and we have recorded no failed sandbox provisioning attempts at all since 02:16 UTC. Sandbox start and suspend latency has returned to normal levels.
Our infrastructure provider reports that their service has recovered and is holding their incident in a monitoring state to confirm stability. We are mirroring that posture: this component stays marked as degraded until they close their incident, at which point we will mark it operational.
Tasks that run code or generate files are working normally. No action is needed on your side.
Affected services
Updated
Sep 3, 2026 at 2:19am UTC
Correction: this incident is not fully resolved. Our infrastructure provider's incident is still open.
Task-starting failures stopped at 02:01 UTC and tasks have been completing since, but a portion of sandbox provisioning requests is still failing upstream and being absorbed by automatic retries. The practical effect for you is that tasks which run code or generate files may take longer than usual to start, and there is a risk of renewed failures until the provider completes their fix.
We are keeping this component marked as degraded and monitoring continuously. We will mark it operational only once the upstream incident is closed and our error rate returns to baseline.
Affected services
Updated
Sep 3, 2026 at 2:01am UTC
Sandbox provisioning recovered at 02:01 UTC and tasks have been completing normally since. Total impact window was approximately 17 minutes.
A small amount of elevated latency remains on an internal sandbox suspend operation. This is not user-visible and does not affect task execution; we are monitoring it.
Affected services
Created
Sep 3, 2026 at 1:44am UTC
Between 01:44 and 02:01 UTC on September 3, tasks that run code, generate files, or execute shell commands failed to start. Affected tasks returned an error in the conversation instead of completing, and some stalled before timing out.
The cause was an outage at the third-party infrastructure provider that hosts our task sandboxes. Their gateway rejected sandbox provisioning requests for the duration of the window, so retries could not succeed either.
Regular chat, search, and people and company lookups were not affected during this period.
Service has recovered and new tasks are running normally. If a task of yours failed in this window, please run it again. We are following up with the provider.
Affected services